Instalando o pg gem no Mavericks para usar com Postgres.app

Postgres.app

Vá para http://postgresapp.com/ , baixe a versão mais recente e instale-a. No momento em que este artigo foi escrito, a versão mais recente é 93 e o nome do aplicativo é Postgres93.app .

Apple Developer Tools

Certifique-se de ter as ferramentas de desenvolvedor instaladas. Se você instalou o XCode, pode pular esta etapa.

xcode-select --install

Homebrew

Se você não instalou o homebrew antes, vá em frente.

ruby -e "$(curl -fsSL https://raw.github.com/mxcl/homebrew/go)"

Quando terminar, certifique-se de que o homebrew está pronto para começar.

brew doctor

No meu caso, tive que instalar o compilador gcc 4.2, mas isso pode n√£o ser necess√°rio.

brew install apple-gcc42

PG Gem

E, finalmente, instale o pg gem especificando a op√ß√£o –with-pg-config :

gem install pg -- --with-pg-config=/Applications/Postgres93.app/Contents/MacOS/bin/pg_config